You are not logged in.

#1 2012-08-31 21:39:52

ntibix
Member
Registered: 2012-07-13
Posts: 59

[REZOLVAT]/mnt

Salutare!
In /srv/http/ am un symlink catre /mnt unde este index.php.
Daca rulez
$ firefox localhost/mnt/index.php
nu apare nimic in fereastra firefox si nici o eroare .
/mnt si index.php au drept acces 777 owner tibi.
Continut /etc/httpd/conf/httpd.conf :
<Directory "/srv/http">
     Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride FileInfo
#     AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

nici cu AllowOverride All nu merge.
Multumesc.

Last edited by ntibix (2012-11-26 23:53:31)

Offline

#2 2012-09-01 00:03:15

wonder
Moderator
From: București
Registered: 2009-07-03
Posts: 722

Re: [REZOLVAT]/mnt

ce ai in index.php? ar trebui sa mearga, fa un test avand phpinfo(); si vezi daca apar chestii pe acolo.


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2012-09-01 02:05:34

ntibix
Member
Registered: 2012-07-13
Posts: 59

Re: [REZOLVAT]/mnt

Exact phpinfo() am.
Acum opresc apache si pornesc Xamp.
# /opt/lampp/lampp start
si cu
$ firefox localhost/mnt/index.php
apare phpinfo.Bineinteles am si in /opt/lampp/htdocs un ~mnt symlink catre /mnt
in /opt/lampp/etc/http.conf am:
DocumentRoot "/opt/lampp/htdocs"
<Directory "/opt/lampp/htdocs">
    Options Indexes FollowSymLinks ExecCGI Includes

    AllowOverride All
    Require all granted
</Directory>
Daca refac aceasta configuratie de Xamp in lamp si
repornesc apache
# rc.d start httpd
$ firefox localhost/mnt/index.php   obtin Access forbidden  Error 403
din cauza
Require all granted. Dar totusi Xampp executa phpinfo() . Nu mai inteleg nimic.

Offline

#4 2012-09-01 18:38:53

wonder
Moderator
From: București
Registered: 2009-07-03
Posts: 722

Re: [REZOLVAT]/mnt

redenumeste index.php in altceva si vezi daca apare fisierul cand rulezi firefox http://localhost/mnt


Give what you have. To someone, it may be better than you dare to think.

Offline

#5 2012-09-03 21:34:41

ntibix
Member
Registered: 2012-07-13
Posts: 59

Re: [REZOLVAT]/mnt

Nu merge nici asa.

Offline

#6 2012-11-26 23:52:58

ntibix
Member
Registered: 2012-07-13
Posts: 59

Re: [REZOLVAT]/mnt

In  /etc/php/php.ini am adaugata  /mnt/ la linia

open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/ :/mnt/ 

si acuma merge.

Offline

Board footer

Powered by FluxBB